Tuesday, September 29, 2009

network management

I'll try to explain how to create link aggregation a.ka. Ether channe(AIX), Net-bond(Linux).

Before we create one, we have to know, how many interfaces are present in that system.

List network interfaces.

AIX

# lsparent -C -k ent
ent0 Available 03-08 10/100/1000 Base-TX PCI-X Adapter (14106902)
ent1 Available 03-09 10/100/1000 Base-TX PCI-X Adapter (14106902)



Linux

systool -c net
Class = "net"

Class Device = "bond0"
Device = "0000:02:01.0"

Class Device = "eth1"
Device = "0000:02:05.0"

Class Device = "lo"

Class Device = "sit0"


ip link show
1: lo: mtu 16436 qdisc noqueue


link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:0c:29:81:c0:13 brd ff:ff:ff:ff:ff:ff
3: sit0: mtu 1480 qdisc noop
link/sit 0.0.0.0 brd 0.0.0.0

Solaris

# dladm show-dev
e1000g0 link: up speed: 1000 Mbps duplex: full
e1000g1 link: up speed: 1000 Mbps duplex: full

change NIC settings to full duplex/Autoneg

AIX

chdev -l 'ent0' -a media_speed='1000_Full_Duplex'

Linux
ethtool -s speed 1000 duplex full autoneg on
ethtool --change eth0 autoneg off speed 1000 duplex full

ethtool eth0 (same as entstat ent0 on AIX)

Solaris

http://www.sun.com/bigadmin/jsp/descFile.jsp?url=descAll/how_to_set_your_nic
http://sysunconfig.net/unixtips/set_nic_settings.txt


Etherchannel configuration




AIX

smitty etherchannel

very easy huh :)

Linux
# ls "$PWD/ifcfg-eth0"
/etc/sysconfig/network-scripts/ifcfg-eth0
# cat ifcfg-eth0

MASTER=bond0
DEVICE=eth0
SLAVE=yes
ONBOOT=yes
USERCTL=no
BOOTPROTO=none

#cat ifcfg-eth1

MASTER=bond0
DEVICE=eth1
SLAVE=yes
ONBOOT=yes
USERCTL=no
BOOTPROTO=none

add/append following lines to /etc/modprode.conf
alias bond0 bonding
options bond0 mode=balance-alb miimon=100

modprobe bonding (for loading bond module)

service network restart
less /proc/net/bonding/bond0
Output
Ethernet Channel Bonding Driver: v3.2.4 (January 28, 2008)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 0
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:0c:29:81:c0:13

Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:0c:29:81:c0:1d


Refer: http://www.linuxfoundation.org/en/Net:Bonding



Solaris





the last step changes the hostname on to aggr1 .
A reboot is required .

For setting jumboframes
edit MaxFrameSize /kernel/drv/e1000g.conf/hme.conf
edit AutoNegAdvertised for setting full duplex etc


# dladm show-aggr -s
key: 1 ipackets rbytes opackets obytes %ipkts %opkts
Total 3930 408207 2337 222124
e1000g0 3084 309475 1601 158419 78.5 68.5
e1000g1 846 98732 736 63705 21.5 31.5

Check below link for SOlaris dladm and ethtool comparison

http://hub.opensolaris.org/bin/view/Project+brussels/ethtool-dladm-comparison




No comments:

Post a Comment